当前位置: 首页 > 系统与网络 > 正文

[分享]花生壳 Oray 在RouterOS上的DDNS动态域名设置

ros-scripts

设置方法:
System-Scrpits 里面点击 + 新建一个脚本,这里名为ddns-pppoe-1。在Source里面输入以下内容:
local ipaddr
:set ipaddr [/ip address get [/ip address find interface=pppoe-out-1] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
local server “http://ddns.oray.com”
local domain “domain”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “username”
local paswd “password”
/tool fetch url=($server . $par) mode=http user=$users password=$paswd

System-Scheduler 里面点击 + 新建一个脚本,这里名为schedules-ddns,在Start Time中下拉菜单选择startup,在On Event:输入以下内容:
/system script run ddns-pppoe-1

将内容依次替换为自己的设置:
interface=pppoe-out-1 将 pppoe-out-1 替换成你在ROS中需要使用动态域名的接口
local domain “domain” 双引号中的 domain 替换成你的ddns域名
local users “username” 双引号中的 username 替换成你在花生壳的登陆用户名
local paswd “password” 双引号中的 password 替换成你在花生壳的登陆密码
测试可以使用 http://ddns.oray.com/ph/update?&hostname=你的ddns域名&myip=你要设置的IP或者动态IP

/system script run ddns-pppoe-1 将 ddns-pppoe-1 替换成你在 System-Scrpits 中新建的脚本名称。

若更新成功 则会在Log中显示如下信息:
ddns-success

更新:2016年2月3日

本文固定链接: http://blog.ich8.com/post/5853 | 霸王硬上弓's Blog

avatar
该日志由 霸王硬上弓 于2016年01月26日发表在 系统与网络 分类下, 你可以发表评论,并在保留原文地址及作者的情况下引用到你的网站或博客。
原创文章转载请注明: [分享]花生壳 Oray 在RouterOS上的DDNS动态域名设置 | 霸王硬上弓's Blog

[分享]花生壳 Oray 在RouterOS上的DDNS动态域名设置:等您坐沙发呢!

发表评论

您必须 [ 登录 ] 才能发表留言!