当前位置: 首页 > 系统与网络 > 正文

[分享]解决OPENWRT编译gst-plugins-base提示没有找到gstreamer

近日在编译openwrt的gst-plugins-base组件时候,出现如下错误信息:

configure: No package ‘gstreamer-0.10’ found
configure: error: no gstreamer-0.10 >= 0.10.36 (GStreamer) found

提示缺少gstreamer-0.10的支持,且版本要≥0.10.36。编译系统是ubuntu server 13.10版本,通过源安装了libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev,依旧提示找不到,火大,直接sudo apt-get install gstreamer* 和libgstreamer*全给装上了………………..其实是迫不及待想知道结果。但还是找不到。。无奈尝试手工安装gstreamer。

安装准备:

先从http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-0.10.36.tar.gz下载0.10.36版本的gstreamer。
tar -zxvf gstreamer-0.10.36.tar.gz -C gstreamer
./configure
make
make install

这里gstreamer是默认路径安装,没有设置–prefix,我们添加 export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH 就可以了。

本文固定链接: http://blog.ich8.com/post/4258 | 霸王硬上弓's Blog

avatar
该日志由 霸王硬上弓 于2013年12月29日发表在 系统与网络 分类下, 你可以发表评论,并在保留原文地址及作者的情况下引用到你的网站或博客。
原创文章转载请注明: [分享]解决OPENWRT编译gst-plugins-base提示没有找到gstreamer | 霸王硬上弓's Blog

[分享]解决OPENWRT编译gst-plugins-base提示没有找到gstreamer:等您坐沙发呢!

发表评论

您必须 [ 登录 ] 才能发表留言!